Question

More than one control found for action Blue Jeans." error

  • 17 April 2024
  • 3 replies
  • 553 views

Badge

Hello Everyone,

I enrolled in Tricentis Tosca Fundamentals - Automating web application testing (AS1).

I completed 41% so far, but I'm facing an issue. When I run my testcase against the test site https://demowebshop.tricentis.com/, it fails to locate this highlighted link:

 

 

Here's the error message:

 

I rescanned the Module where the object is located and made it unique by selecting one of its unique properties. However, I still encounter the same error.

This error surprises me because I used the default Modules provided with the Tosca base project. It was mentioned in the course that we wouldn't need to change their properties as the controls within the modules were already stable!

Any insights would be appreciated.

Kinfly.

 


3 replies

I’m doing the same course, and I hit the same thing.
Try emptying your shopping cart.

I think that it’s possibly because at some point your test hasn’t completed, so you now have items (like blue jeans) in your Shopping Cart, and that is picking up the duplicate reference (to blue jeans)

I initially resolved this issue by rescanning and adding an anchor for the blue jeans object (but then hit the same issue with price no longer being unique).  At which point I realised where these additional references were coming from.

Hope that this helps.

Badge

Hello @Rattus72 !

I trust you are well.

Firstly, thank you for taking the time to respond to my inquiry.

Indeed, I encountered the same issue!

Once I corrected the reference to the Blue Jeans, the price one was duplicated!

I will attempt your solutions and inform you of any resolution to the duplicated reference issue with the price object.

Kindly.

Badge

Hi @Rattus72 !

You are indeed correct!

It is now functioning properly!

I wish they had mentioned it in the course; it would have saved time.

Though I'm encountering other error types, I'm actively addressing them.

As for my last inquiry, could you advise on implementing try/catch blocks or enabling debugging mode?

It would greatly assist in handling the current error: "The value '10.00' cannot be interpreted as numeric." Even though its type is “Numeric”.

Thank you once more for your assistance!

Kindly.

Reply