Solved

Using TOSCA Server Repository - Not all elemenst visible in local repository

  • 13 October 2023
  • 1 reply
  • 28 views

Userlevel 3
Badge

Hi all,

I use the Tosca Server 15.0 Path 4 and MSSQL Server 2018. On the clients I use the TOSCA Server Repository and I am able to get all data from the server. When I create a new  workspace  on my client (Tricentis Server Repository or MS SQL Server) everythiing is avaialable (all modules, testcase, congigurations and execution lists). When I close the project and open it again some modules or tescases are missing (always different items). When I use the update function the issue is still the same. The only workaround is to create again a new workspace and working on it. Do you have an idea what might be the issue? On the client I use TOSCA 2023.1

 

[Originally asked and solved on Support Hub]

icon

Best answer by Community Administrator 13 October 2023, 14:23

View original

1 reply

Userlevel 4
Badge +2

This is a known issue with the feature "Auto Exclusion". To resolve for all workspaces I recommend doing the following:

  1. Setup a project level override to set Settings>Commander>General>Auto Exclusion>Enabled to False . If you don't do it at the project level you will have to sign into each machine with Tosca installed and change the setting to false.
  2. Delete and recreate any and all affected workspaces. Any workspaces already affected will not be fixed by this change, so they need to be recreated.

My TCProjectSetting Looks like this:
35eec0f333e9b990b8c0c37c2d5c7b7f.iix

I do see that the label for it in settings is  "Off" sorry for the confusion:

2d3f00b733e9b990b8c0c37c2d5c7b21.iix

 

I hope this helps!

Reply