Solved

PlaywrightException: Executable doesn't exist

  • 6 February 2024
  • 1 reply
  • 32 views

Hi, our team has taken over a NeoLoad-script that was built by another company. The nlp contains product.version=9.2.1. 
I already had version 8.2.4 installed for our own scripts on Windows Server 2019 and I installed 9.2.4 to open this script.

The script is a Real Browser script and when run “check a user path” it immediately fails because the executable doesn't exist at “C:\Program Files\NeoLoad 9.2\browsers\chromium-1033\chrome-win\chrome.exe”.
I see in the 9.2 browsers folder that the chromium-folder is chromium_win64_special-1050. I tried changing the path in Preferences → General settings → Browsers → Google Chrome to "C:\Program Files\NeoLoad 9.2\browsers\chromium_win64_special-1050\chrome-win\chrome.exe”, but the “check a user path” still fails.
 

Is there another place where the path for Chromium is configured? 
The ugly workaround is to rename chromium_win64_special-1050 to chromium-1033

icon

Best answer by Nouredine 7 February 2024, 16:33

View original

1 reply

Badge +1

Hello, i think there’s an issue with the browser folder name. The right folder name should really be “chromium-1033”. It was this name in 9.2.3 version. So renaming it is not as ugly as it sounds.

I reproduced that issue and raised it to our team. Renaming the folder worked fine.

Reply